Software Requirements

SOFTWARE
Internet Explorer 8, 9, 10, or 11 on Windows 7, 8 or 10Certain client programs may require specific versions of Windows. Windows 8/8.1 not supported by some clients. Please see the Client Opportunity Announcement for details.

(Optional) Mozilla Firefox or Chrome for Windows
Microsoft Security Essentials for Windows 7; Windows Defender for Windows 8 or 10 Other security software may be incompatible and should be avoided. Technical support may be refused if your company’s software configuration is not compatible with the Arise Platform or is determined to cause incompatibilities with client required servicing software.

Call Centers and their agents are responsible for maintaining the security and reliability of their equipment. The following items are considered security risks to the Arise Platform and, upon detection, may subject your company to the suspension or termination of its MSA or SOW:
▪ Malware infected software
▪ Virtualized Operating Systems (i.e.: VMWare, Parallels, etc.)
▪ Non-Arise provided VPN software or Proxy settings
▪ TOR or other privacy software